"

gSpeak Build 6xx – library for MetaTrader 4

by Dr.Hamdi Boukamcha

gSpeak Build 6xx – library for MetaTrader 4

Ahmed Soliman

Files:
speak.mq4 (0.46 KB)view
speak_b6.zip (15.5 KB)

Author:

Coders’ Guru

Description:

One of my clients asked my to update his indicator from the 509 build to work with MT4 Build 610.

Eveything is cool and easy. But he want to use my old gSpeak dll.

If you don’t know what the gSpeak.dll: The dll enable you to speak the Alert using the build in window TTS engine.

But after the string handling change in Build 6xx my old gSpeak is not working anymore.

That’s why I update the gSpeak.dll to work with the new Build.

 

bool gSpeak(string text, int rate, int volume);

This is the only function. As you see I merged the old two functions in gSpeak in one function that you can set the voice rate and volume from one place.

 

Enjoy
CG

gSpeak Build 6xx - library for MetaTrader 4
codersguru | 22 Mar 2014 at 06:07
The dll and the code updated!
gSpeak Build 6xx - library for MetaTrader 4
mql4_comments | 25 Mar 2014 at 18:01

I’ve now tried the updated dll and it works just fine.

Thank’s codersguru

gSpeak Build 6xx - library for MetaTrader 4
Roddo | 31 Mar 2014 at 06:36

Thanks CG.

I am glad you have put your new gSpeak Build 6xx out there I am a BIG fan.

Cheers

Rod

gSpeak Build 6xx - library for MetaTrader 4
codersguru | 1 Apr 2014 at 05:23
Roddo:
Thanks CG.

I am glad you have put your new gSpeak Build 6xx out there I am a BIG fan.

Cheers

Rod

Thanks Rod! I hope it helps.

gSpeak Build 6xx - library for MetaTrader 4
codersguru | 1 Apr 2014 at 05:24
dogerman:
I’ve now tried the updated dll and it works just fine.

Thank’s codersguru

Your welcome! I hope it helps!

Share this article

Leave a comment